Home Page Forums Dew Error when installing ThemeVan Core

This topic is: not resolved
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #31748
    Graham Ferguson
    Participant
    Post count: 6

    I have just purchased the Dew theme and installed the theme and then the child theme on a fresh install of the latest WordPress version. On installing and then activating the ThemeVan Core plugin which is marked as required I am then given an error and cannot use my site, the error is:

    Fatal error: Declaration of CMB2_Type_Colorpicker::render() must be compatible with CMB2_Type_Text::render($args = Array) in /home/cdkeydi6/public_html/easygpldownloads.com/wp-content/plugins/themevan-core/core/integration/metabox/includes/types/CMB2_Type_Colorpicker.php on line 13

    No other plugin’s are installed other than those which come with vanilla WordPress.

    Please advise how this can be resolved.

    #31750
    Graham Ferguson
    Participant
    Post count: 6

    Ok, I can see this is a common problem when I google. It looks like an issue with using PHP 7.2 which I typically do, I have downgraded to PHP 7 and it works. Is there anyway to resolve so I can use 7.2?

    #31756
    John Wu
    Keymaster
    Post count: 184

    Sorry for the delay!

    Because that Error is generated by CMB2 (A 3rd-party plugin which is integrated into ThemeVan Core), so I will give this plugin developer a feedback soon.

    Thanks

    #31758
    Graham Ferguson
    Participant
    Post count: 6

    Thanks, reading the various threads online I believe the most recent versions of this plugin (CMB2) have resolved this issue.

    #31766
    John Wu
    Keymaster
    Post count: 184

    I will include the latest version of CMB2 in the ThemeVan Core plugin.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
×